Solution pour flutter create is not a valid dart package name

flutter create is not a valid dart package name

Grâce à Flutter, vous pouvez maintenant créer des applications sur de nombreuses plateforme. Mais lorsqu’on débute vous pouvez rencontrer des erreurs.

Dans cette article, une erreur courante lorsque vous créez un nouveau projet via la console.
Vous devez écrire la commande suivante pour créer un nouveau projet :

flutter create --org com.votrenomdedomaine nom_de_votre_appi

Vous pouvez avoir comme erreur :

"Nom_du_projet" Is not a valid Dart package name 
 
See https://dart.dev/tools/pub/pubspec#name for more information.


Pourquoi cette erreur ?

Il m’est arrivé d’avoir l’erreur Is not a valid Dart package name, succédé par le nom de mon projet.

Le problème est simple, Pas de majuscule dans le nom de votre projet, Sinon Flutter prendra cela comme une class à ajouter à votre projet.

Voilà une erreur que beaucoup de gens passe du temps à trouver la solution qui est si simple, mais il faut le savoir.